1. 23 Mar, 2022 2 commits
    • Lorenzo "Palinuro" Faletra's avatar
      Import Debian changes 1.13.1+dfsg-2parrot1 · baa57fad
      Lorenzo "Palinuro" Faletra authored and Nong Hoang Tu's avatar Nong Hoang Tu committed
      ruby-nokogiri (1.13.1+dfsg-2parrot1) parrot-updates; urgency=medium
      .
        * Import new Debian version.
      .
      ruby-nokogiri (1.13.1+dfsg-2) unstable; urgency=medium
      .
        * Breaks ruby-sanitize 5.2.3 and earlier, and ruby-nokogumbo
        * Newer version than 1.12 (Closes: #993830)
      .
      ruby-nokogiri (1.13.1+dfsg-1) unstable; urgency=medium
      .
        * Reupload to unstable
        * Fix syntax in lintian overrides
        * typo in excluding pattern for java files
        * remove also ext/ in rubygems-integration subdirs
      .
      ruby-nokogiri (1.13.1+dfsg-1~exp1) experimental; urgency=medium
      .
        * New upstream version 1.13.1+dfsg
        * Use rake method to run tests
        * Build-depend on racc, rake-compiler, rubocop and ruby-mini-portile2
        * Delete artificial gemspec as there is one in the source tree
          + Do not filter out miniportile2 anymore from gemspec
          + Remove jar files in the file list in gemspec
        * Refresh patches
        * Add 0005-Remove-unnecessary-development-dependencies.patch to roughly get
          rid of unneeded gems listed as development dependencies
        * SET NOKOGIRI_SPEC variable for tests
        * debian/rules
          + exclude ext/nokogiri/java from installation path
          + Remove afterwards installed copies of gumbo-parser source
          + enable hardening
        * Remove rake-compiler-dock
        * tests:read specifications without bundler
        * Add copyright info for gumbo-parser
        * Override some lintian messages about long lines in tests
      .
      ruby-nokogiri (1.11.7+dfsg-3) unstable; urgency=medium
      .
        * use gem install layout
        * Manually install ext/nokogiri/nokogiri.h header to the
          RbConfig::CONFIG["vendorhdrdir"] (Closes: #993829)
        * gemspec target: move filtering to d/filter_gemspec script
        * Add 0002-Ignore-mismatching-versions-of-libs.patch to ignore spurious
          warnings (Closes: #993818)
      .
      ruby-nokogiri (1.11.7+dfsg-2) unstable; urgency=medium
      .
        * Reupload to unstable
        * Bump Standards-Version to 4.6.0 (no changes needed)
      .
      ruby-nokogiri (1.11.7+dfsg-1) experimental; urgency=medium
      .
        * New upstream version 1.11.7+dfsg
        * Use environment variable instead of 0004-Always-use-system-libraries.patch
      .
      ruby-nokogiri (1.11.1+dfsg-2) unstable; urgency=medium
      .
        [ Helmut Grohne ]
        * Annotate test dependencies <!nocheck>. (Closes: #981388)
      .
      ruby-nokogiri (1.11.1+dfsg-1) unstable; urgency=medium
      .
        [ Debian Janitor ]
        * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
          Repository-Browse.
      .
        [ Cédric Boutillier ]
        * [ci skip] Update team name
        * [ci skip] Add .gitattributes to keep unwanted files out of the
          source package
      .
        [ Pirate Praveen ]
        * Remove coverage/* in clean target
      .
        [ Debian Janitor ]
        * Set upstream metadata fields: Security-Contact.
      .
        [ Lucas Nussbaum ]
        * New upstream version 1.11.1+dfsg
          + Fixes CVE CVE-2020-26247. Closes: #978967
        * Bump debhelper compat to 13
        * Bump Standards-Version to 4.5.1
        * Add Rules-Requires-Root
        * Refresh patches
        * debian/rules gemspec: Force platform to ruby to download source gem
        * Update gemspec
        * Replace ruby-tests.rake by ruby-tests.rb to avoid issues with
          nokogiri's rake libs
        * Add some new build-dependencies
      .
      ruby-nokogiri (1.10.9+dfsg-1) unstable; urgency=medium
      .
        * Change repacksuffix to just +dfsg (it was +dfsg1)
        * New upstream version 1.10.9+dfsg
        * Update gemspec file to match new version
      .
      ruby-nokogiri (1.10.7+dfsg1-2) unstable; urgency=medium
      .
        * Rebuilt against Ruby2.7.
        * debian/control:
          - Bump Standards-Version to 4.5.0.
      .
      ruby-nokogiri (1.10.7+dfsg1-1) unstable; urgency=medium
      .
        [ Georg Faerber ]
        * New upstream version 1.10.4+dfsg1
        * debian/control: Use HTTPS in Homepage field
        * debian/copyright: Use HTTPS in Homepage field
      .
        [ Pirate Praveen ]
        * New upstream version 1.10.7+dfsg1
      .
      ruby-nokogiri (1.10.4+dfsg1-1) unstable; urgency=medium
      .
        * New upstream version. (Closes: #934802)
        * Drop compat file, add Build-Dependency on debhelper-compat.
        * Use my debian.org mail address.
        * Update gemspec file to 1.10.4.
      .
        [ Utkarsh Gupta ]
        * Add salsa-ci.yml
      .
      ruby-nokogiri (1.10.3+dfsg1-2) unstable; urgency=medium
      .
        * Reupload to unstable
      .
      ruby-nokogiri (1.10.3+dfsg1-1) experimental; urgency=medium
      .
        * New upstream version 1.10.3+dfsg1
        * Bump Standards-Version to 4.4.0 (no changes needed)
        * Refresh patches
        * Add a check to verify debian/gemspec is updated
        * Update gemspec file to 1.10.3
      .
      ruby-nokogiri (1.10.1+dfsg1-1) experimental; urgency=medium
      .
        * New upstream version 1.10.1+dfsg1
        * Update gemspec from rubygems.org
        * Refresh patches
        * Add ruby-simplecov as build dependency
      .
      ruby-nokogiri (1.10.0+dfsg1-2) unstable; urgency=medium
      .
        * Team upload
        * Add Breaks for ruby-sanitize
      .
      ruby-nokogiri (1.10.0+dfsg1-1) unstable; urgency=medium
      .
        [ Cédric Boutillier ]
        * New upstream version 1.10.0+dfsg1
        * Use Github as source
        * Update Files-Excluded paragraph in copyright file to exclude jar files
          from source
        * Remove ourdated Readme.source file
        * Refresh 003-Remove-dependency-on-mini_portile2.patch
        * Create rule to retrieve gemspec from corresponding .gem
      .
        [ Utkarsh Gupta ]
        * Bump Standards-Version to 4.3.0 (no changes needed)
        * Update watch and rules file
      .
      ruby-nokogiri (1.10.0-1) unstable; urgency=medium
      .
        * Team upload
        * New upstream version 1.10.0
        * Update patch file names with the serial number
        * Refresh patches
      .
      ruby-nokogiri (1.9.1-1) unstable; urgency=medium
      .
        * Team upload
        * New upstream version 1.9.1
        * Bump Standards-Version to 4.3.0 (no changes needed)
        * Move debian/watch to gemwatch.debian.net
        * Refresh patches
        * Update debian/rules
      .
      ruby-nokogiri (1.8.4-1) unstable; urgency=medium
      .
        * New upstream version 1.8.4
        * Move debian/watch to gemwatch.debian.net
        * Bump Standards-Version to 4.1.5 (no changes needed)
        * Trivially refresh patches
      .
      ruby-nokogiri (1.8.2-1) unstable; urgency=medium
      .
        * New upstream release.
        * debian/changelog: Remove trailing whitespaces.
        * debian/compat: Bump debhelper version to 11.
        * debian/control:
          - Add myself to Uploaders.
          - Bump required debhelper version to >= 11~.
          - Bump Standards-Version to 4.1.3, no changes needed.
          - Use salsa.debian.org in Vcs-{Git,Browser}: fields.
        * debian/copyright: Use HTTPS in link to copyright format spec.
        * debian/watch:
          - Bump version to 4.
          - Use HTTPS in link to gemwatch service.
      .
      ruby-nokogiri (1.8.1-1) unstable; urgency=medium
      .
        [ Antonio Terceiro ]
        * Remove myself from Uploaders:
      .
        [ Cédric Boutillier ]
        * New upstream version 1.8.1
        * Refresh 0003-Remove-dependency-on-mini_portile2.patch
        * Bump Standards-Version to 4.1.0 (no changes needed)
      .
      ruby-nokogiri (1.8.0-1) unstable; urgency=medium
      .
        * New upstream version 1.8.0
        * Refresh patches.
        * Drop 0005-skip-test-incompatible-with-libxml2-from-Debian.patch
          (upstream also added a skip stanza)
        * Bump Standards-Version. No changes needed.
        * CHANGELOG.rdoc has been renamed to CHANGELOG.md
      .
      ruby-nokogiri (1.6.8.1-1) unstable; urgency=medium
      .
        * New upstream release
        * Add myself to Uploaders:
        * Rework patche stack to use gbp-pq
        * Skip one test that is incompatible with libxml2 currently in Debian
          (Closes: #842910)
      .
      ruby-nokogiri (1.6.8-2) unstable; urgency=medium
      .
        * Add missing dependency on ruby-pkg-config (Closes: #829171, #829175)
      .
      ruby-nokogiri (1.6.8-1) unstable; urgency=medium
      .
        * Team upload
        * Imported Upstream version 1.6.8
        * Refresh patches
          - skip-some-tests.patch: dropped, issues fixed upstream
        * New build-dependency: ruby-pkg-config
        * Bump Standards-Version: to 3.9.8, no changes needed
      .
      ruby-nokogiri (1.6.7.2-3) unstable; urgency=medium
      .
        * Team upload.
        * Sourceful upload to build with current ruby-defaults.
      .
      ruby-nokogiri (1.6.7.2-2) unstable; urgency=medium
      .
        * Reupload to unstable
        * Add myself to uploaders
      .
      ruby-nokogiri (1.6.7.2-1) experimental; urgency=medium
      .
        * Team upload
        * New upstream hotfix release
        * Refresh patches
        * Bump standards version to 3.9.7
        * Switch to https for vcs-git url
      .
      ruby-nokogiri (1.6.7.1-1) unstable; urgency=medium
      .
        * Team upload
        * New upstream hotfix release
      .
      ruby-nokogiri (1.6.7-1) unstable; urgency=medium
      .
        * Team upload
        * New upstream release
          - Refresh patches
        * debian/ruby-nokogiri.docs: updated to reflect renaming/removal of upstream
          README files
      .
      ruby-nokogiri (1.6.6.3-1) unstable; urgency=medium
      .
        * Team upload
        * New upstream release
        * Refresh patches
        * Refresh packaging:
          - dump debian/compat to 9
          - reformat debian/control
          - update debian/ruby-tests.rake
          - cleanup debian/rules
        * switch running tests to debian/ruby-tests.rake
        * skip-some-tests.patch: skip tests that won't work against libxml2 2.9.2 in
          Debian, but pass when using the embedded copy + patches in the Nokogiri
          tree (Closes: #800028)
        * debian/copyright: explicitly list files that are excluded from the
          tarball, so that stuff is removed from the tarball by uscan
      .
      ruby-nokogiri (1.6.6.2+ds-2) unstable; urgency=medium
      .
        * Team upload.
        * Re-upload to unstable.
      .
      ruby-nokogiri (1.6.6.2+ds-1) experimental; urgency=low
      .
        * Team upload.
        * New upstream release.
        * Bump standards version to 3.9.6 (no changes).
        * Refresh patches.
      .
      ruby-nokogiri (1.6.3.1+ds-1) unstable; urgency=medium
      .
        * Imported Upstream version 1.6.3.1+ds
        * Refresh always_use_system_libraries.patch
      .
      ruby-nokogiri (1.6.2.1+ds-1) unstable; urgency=medium
      .
        * Imported Upstream version 1.6.2.1+ds
        * Refresh patches
        * Build-depend on pkg-config
        * Drop support for ruby2.0
      .
      ruby-nokogiri (1.6.1+ds-4) unstable; urgency=medium
      .
        * Team upload
        * Remove mini_portile from metadata.yml
      .
      ruby-nokogiri (1.6.1+ds-3) unstable; urgency=medium
      .
        * Team upload.
        * Bump gem2deb build dep to >= 0.7.5~
          - Fix for #743664
      .
      ruby-nokogiri (1.6.1+ds-2) unstable; urgency=low
      .
        * Team upload.
        * Bump gem2deb build dep to 0.7.4~
          - drop ruby1.9.1
      .
      ruby-nokogiri (1.6.1+ds-1) unstable; urgency=medium
      .
        * Imported Upstream version 1.6.1+ds
          - version 1.6.1 fixes security issues CVE-2013-6460 CVE-2013-6461
            (Closes: #734836)
        * Mention in copyright file and README.source that the tarball is
          repacked to remove convenience copies
        * Add a dversionmangle option in debian/watch
        * Bump Standards-Version to 3.9.5 (no changes needed)
      .
      ruby-nokogiri (1.6.0-1) unstable; urgency=low
      .
        * Team upload.
        * New upstream release:
          - Strip embedded code copy from upstream source.
          - Update patches:
            remove-annoying-warning.patch: refreshed;
            fix_tests_assert_match.patch: deleted, merged upstream;
            minitest5_support.patch: deleted, merged upstream.
          - Add a patch to always use the system libraries.
        * Stop fiddling test/files/bogus.xml now that its properly shipped
          in upstream tarball.
      .
      ruby-nokogiri (1.5.9-3) unstable; urgency=low
      .
        * add deactivate_test_reader_blocking.patch, deactivating a test hanging on
          kFreeBSD ports
        * build against gem2deb >= 0.5.0~ to add ruby2.0 and drop ruby1.8 support
      .
      ruby-nokogiri (1.5.9-2) unstable; urgency=low
      .
        * Do not exclude test/xml/test_xinclude.rb from tests anymore
        * debian/patches: add 2 patches to fix FTBFS (Closes: #714930)
          + minitest5_support.patch: add support for MiniTest 5
          + skip_test_reader_entity_reference_without_dtdload.patch: disable tests
            failing with libxml2 2.9
      .
      ruby-nokogiri (1.5.9-1) unstable; urgency=low
      .
        * New upstream version
        * debian/rules:
          + create empty file missing from the archive for the purpose of tests
          + install upstream changelog
        * debian/copyright:
          + update my email address and year
        * debian/control:
          + update my email address
          + bump Standars-Version to 3.9.4 (no changes needed)
          + remove obsolete DM-Upload-Allowed flag
          + use canonical anonscm.debian.org URLs for Vcs-* fields
          + remove obsolete transitional packages
        * debian/source:
          + remove lintian-overrides, about transtional packages
        * debian/patches/:
          + remove include_missing_test_document_url_directory.patch, missing file
            added upstream
          + add fix_tests_assert_match.patch to make tests pass with minitest gem
        * update manpage nokogiri(1) to take into account new options
      .
      ruby-nokogiri (1.5.5-1) unstable; urgency=low
      .
        * New upstream version
        * Build-depend on gem2deb >= 0.3.0~
        * add include_missing_test_document_url_directory.patch
          + include test/files/test_document_url/ missing from the gem released by
            upstream
        * cosmetic refreshment of remove-annoying-warning.patch
      .
      ruby-nokogiri (1.5.4-1) unstable; urgency=low
      .
        * New upstream version
        * Drop fix-format-security-issue.patch: included upstream
      .
      ruby-nokogiri (1.5.3-1) unstable; urgency=low
      .
        * New upstream version
        * debian/patches:
          + drop fix-sporadically-failing-tests.patch (applied upstream)
          + add fix-format-security-issue.patch (cherrypicked from upstream)
             Fixes FTBFS with -Werror=format-security flag (Closes: #676207)
      .
      ruby-nokogiri (1.5.2-1) unstable; urgency=low
      .
        * New upstream version
        * Add myself to Uploaders:
        * Bump Standards-Version to 3.9.3 (no changes needed)
        * Exclude temporarily test_xinclude.rb from the tests, as xinclude.xml is
          missing in this version
        * Add fix-sporadically-failing-tests.patch (Closes: #661690)
        * Set Priority: to extra for transitional packages
        * Override lintian warnings about duplicate decription for transitional
          packages
        * Convert copyright file to DEP-5
        * Provide a simple manpage for nokogiri binary
      .
      ruby-nokogiri (1.5.0-1) unstable; urgency=low
      .
        * Switch to gem2deb. Rename source and binary packages.
        * New upstream version. Closes: #604623.
      .
      libnokogiri-ruby (1.4.0-4) unstable; urgency=low
      .
        * fix failing tests (and resulting FTBFS) with libxml 2.7.8, thanks to
          Mike Dalessio (Closes: #606296)
      .
      libnokogiri-ruby (1.4.0-3.1) unstable; urgency=low
      .
        * Non-maintainer upload.
        * debian/patches
          - add fix-test_element_description.rb.patch from upstream git to fix
           FTBFS (Closes: #577355)
      .
      libnokogiri-ruby (1.4.0-3) unstable; urgency=low
      .
        * Fix test to also work in UTC. Closes: #566055.
      .
      libnokogiri-ruby (1.4.0-2) unstable; urgency=low
      .
        * Drop 1.9 package, add 1.9.1 package. Closes: #565825.
        * Enable the test suite.
          + Make ruby1.9.1 test suite failures non-fatal.
      .
      libnokogiri-ruby (1.4.0-1) unstable; urgency=low
      .
        * New upstream release
        * update email address
        * close a launchpad bug too
      .
      libnokogiri-ruby (1.3.3-2) unstable; urgency=low
      .
        * add quilt patching
        * get rid of the annoying libxml warning messages (Closes: 546843)
          (LP: 475250)
      .
      libnokogiri-ruby (1.3.3-1) unstable; urgency=low
      .
        * New upstream release
        * Debian Policy 3.8.3
      .
      libnokogiri-ruby (1.3.2-1) unstable; urgency=low
      .
        * new upstream version
        * Debian Policy 3.8.2
        * install the upstream changelog
      .
      libnokogiri-ruby (1.3.1-1) unstable; urgency=low
      .
        * New upstream release
        * improve debian/rules a bit
        * add DMUA field
      .
      libnokogiri-ruby (1.2.3-1) unstable; urgency=low
      .
        * Initial release (Closes: 520583)
      baa57fad
    • Nong Hoang Tu's avatar
      New upstream version 1.13.1+dfsg · ef43bc48
      Nong Hoang Tu authored
      ef43bc48