Commit 37e6caf3 authored by Lorenzo "Palinuro" Faletra's avatar Lorenzo "Palinuro" Faletra
Browse files

Import Debian version 4.11.210223

parrot-core (4.11.210223) rolling-testing; urgency=medium
.
  * Move snap wrapper to apt-parrot.
parent 9289204a
Pipeline #2061 failed with stages
in 0 seconds
......@@ -23,9 +23,7 @@ install:
mkdir -p $(DESTDIR)/lib/systemd/system/postgresql@.service.d
mkdir -p $(DESTDIR)/lib/systemd/system-preset
mkdir -p $(DESTDIR)/sandbox
mkdir -p $(DESTDIR)/usr/local/bin
cp grub.default $(DESTDIR)/etc/default/grub.d/parrot.cfg
cp snap $(DESTDIR)/usr/local/bin/
cp -r systemd/parrot_postgresql.conf $(DESTDIR)/lib/systemd/system/postgresql@.service.d/
cp systemd/80-parrot.preset $(DESTDIR)/lib/systemd/system-preset/
chown root:root $(DESTDIR)/etc/default/grub.d/parrot.cfg
......@@ -34,8 +32,6 @@ install:
chmod 644 $(DESTDIR)/etc/default/grub.d/parrot.cfg
chmod 644 $(DESTDIR)/etc/udev/rules.d/*
chmod 755 $(DESTDIR)/sandbox
chown root:root $(DESTDIR)/usr/local/bin/snap
chmod 755 $(DESTDIR)/usr/local/bin/snap
chmod 644 $(DESTDIR)/lib/systemd/system/postgresql@.service.d/*
chmod 644 $(DESTDIR)/lib/systemd/system-preset/*
mkdir -p $(BUILDDIR)
......
parrot-core (4.11.210223) rolling-testing; urgency=medium
* Move snap wrapper to apt-parrot.
-- Lorenzo "Palinuro" Faletra <palinuro@parrotsec.org> Sun, 21 Feb 2021 09:43:05 +0100
parrot-core (4.11.210222) rolling-testing; urgency=medium
* Bump new compat version.
......
......@@ -2,3 +2,5 @@
%:
dh $@
override_dh_usrlocal:
#!/bin/bash
if [ -x /usr/bin/snapp ]; then
/usr/bin/snap $@
else
echo "SNAP is not currently installed."
echo "SNAP is a universal package manager that works on almost every linux distro"
echo " enabling you to access many programs not currently delivered by"
echo " the official Parrot Security repository."
echo
echo "SNAP is develped by Canonical, the company behind Ubuntu, and it includes"
echo " telemetry that may compromise your privacy or hurt your freedom."
echo " It also allows you to easily install proprietary software"
echo " that may ship further telemetry, perform invasive data collection on you"
echo " and even install malware on your computer."
echo
echo "Please proceed with the installation of SNAP"
echo "only if such conditions are ok for you"
echo "and you accept the consequences."
echo
echo "press ENTER to continue, or CTRL+C to exit"
read
apt update
apt -y install snapd
/usr/bin/snap $@
fi
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment