1. 25 Oct, 2021 4 commits
  2. 07 Sep, 2021 11 commits
  3. 06 May, 2021 3 commits
  4. 23 Jan, 2021 4 commits
  5. 20 Jan, 2021 4 commits
  6. 19 Jan, 2021 6 commits
    • Nong Hoang Tu's avatar
      Update changelog for 3.14.0-0kali2 release · 22c9174f
      Nong Hoang Tu authored
      22c9174f
    • Nong Hoang Tu's avatar
      Add launchers to faraday · 079fc30a
      Nong Hoang Tu authored
      079fc30a
    • Nong Hoang Tu's avatar
    • Nong Hoang Tu's avatar
      Remove Kali's gbp.conf · c1d189a3
      Nong Hoang Tu authored
      c1d189a3
    • Nong Hoang Tu's avatar
      Import Upstream version 3.14.0 · ff3835d7
      Nong Hoang Tu authored
      ff3835d7
    • Sophie Brun's avatar
      Import Debian changes 3.14.0-0kali1 · 232677ed
      Sophie Brun authored and Nong Hoang Tu's avatar Nong Hoang Tu committed
      python-faraday (3.14.0-0kali1) kali-dev; urgency=medium
      .
        [ Kali Janitor ]
        * Wrap long lines in changelog entries: 3.12-0kali1.
        * Set upstream metadata fields: Security-Contact.
      .
        [ Sophie Brun ]
        * New upstream version 3.14.0
        * Refresh patches
        * Add missing build-deps: python3-apispec*
        * Update minimal required version of python3-webargs
        * Don't run tests with nplusone
        * Update debian/py3dist-overrides to include flask_security
        * Add a ptch to fix flask-security requirement
      .
      python-faraday (3.12-0kali1) kali-dev; urgency=medium
      .
        [ Kali Janitor ]
        * Trim trailing whitespace.
        * Move transitional package python-faraday to oldlibs/optional per policy
          4.0.1.
        * Set upstream metadata fields: Bug-Database, Bug-Submit, Repository,
          Repository-Browse.
      .
        [ Sophie Brun ]
        * New upstream version 3.12
        * Build-dep: remove python3-flask-restless
        * Refresh patches
        * Remove failing tests
      .
      python-faraday (3.11.1-0kali3) kali-dev; urgency=medium
      .
        * Try to run migrate-database in postinst only if it's an upgrade of
          faraday, it requires postgresql service. We can't use systemd in
          debian-installer.
      .
      python-faraday (3.11.1-0kali2) kali-dev; urgency=medium
      .
        * Remove useless step in helper-script faraday
      .
      python-faraday (3.11.1-0kali1) kali-dev; urgency=medium
      .
        * New upstream version 3.11.1
        * Refresh patches
        * Fix manpage to remove no-deps option
        * Update minimal required versions in depends and remove useless build-deps
        * Refresh patches
        * Add pgcli in dependency
        * Remove faraday-client usage and manpage
        * Add a debian/py3dist-overrides to generate the Python deps
        * Update helper-script and faraday.service
        * Update information for new version
        * Use embedded glyphicon (display issue with Debian package)
      .
      python-faraday (3.10.2-0kali1) kali-dev; urgency=medium
      .
        * New upstream version 3.10.2
        * Refresh patches
        * Update minimal required versions
      .
      python-faraday (3.10.0-0kali1) kali-dev; urgency=medium
      .
        * New upstream version 3.10.0
        * Refresh patches
        * Switch to Python 3
        * Add missing depends python3-faraday-plugins
        * Rename package to faraday: python-faraday name is not compatible with
          pybuild and python3
        * Add a patch to remove privacy-breach
        * Remove useless python3-gobject
        * Add a patch to switch from psycopg2-binary to psycopg2
        * Update postint to always run our script migrate-database
      .
      python-faraday (3.9.3-0kali1) kali-dev; urgency=medium
      .
        * New upstream version 3.9.3
      .
      python-faraday (3.9.2-0kali1) kali-dev; urgency=medium
      .
        [ Sophie Brun ]
        * Run the tests during the build
        * Add a manpage for faraday
        * Update debian/watch
        * New upstream version 3.9.2
        * Update build-dependencies
        * Refresh patches
      .
        [ Raphaël Hertzog ]
        * Add GitLab's CI configuration file
        * Configure git-buildpackage for Kali
        * Update URL in GitLab's CI configuration file
      .
      python-faraday (3.8.0-0kali1) kali-dev; urgency=medium
      .
        [ Raphaël Hertzog ]
        * Update Vcs-* fields for the move to gitlab.com
      .
        [ Sophie Brun ]
        * New upstream version 3.8.0
        * Update all debian/* files for new version
        * Add manpages for new usptream's scripts
      .
      python-faraday (3.7.0-0kali1) kali-dev; urgency=medium
      .
        * New upstream version 3.7.0
      .
      python-faraday (3.6.0-0kali3) kali-dev; urgency=medium
      .
        * Add a missing depend: python-pip
      .
      python-faraday (3.6.0-0kali2) kali-dev; urgency=medium
      .
        * Prompt the password initialization the first time (see 5366)
      .
      python-faraday (3.6.0-0kali1) kali-dev; urgency=medium
      .
        * New upstream version 3.6.0
      .
      python-faraday (3.5.0-0kali2) kali-dev; urgency=medium
      .
        * Improve database migration in postinst when systemd is not used
      .
      python-faraday (3.5.0-0kali1) kali-dev; urgency=medium
      .
        * New upstream version 3.5.0
        * Update dependencies
        * Bump Standards-Version
        * Update lintian-overrides
        * Refresh patches
        * d/rules: fix permissions
        * Migrate database if upgrade
        * Import upstream patch to fix issues: admin creation and dir creation
      .
      python-faraday (3.4-0kali1) kali-dev; urgency=medium
      .
        * Update debian/copyright
        * New upstream version 3.4
        * Update email address
        * Add missing depends: python-flask-restless
      .
      python-faraday (3.3-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (3.2-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (3.1.1-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (3.0.1-0kali1) kali-dev; urgency=medium
      .
        * Update debian/watch to handle beta version
        * New upstream version 3.0.1
        * Update debian/copyright
        * Update install for new release
        * Refresh patches and remove fix-checkVersion.patch
        * Use debhelper 11 and update Standards-Version
        * Update dependencies
        * Remove build-dep dh-systemd (obsolete package)
        * Remove references to couchdb configuration
        * Add lintian-overrides
        * Clean up to fix several lintian warnings
        * Install the required empty directory migrations/versions
        * Change Architecture to All and clean d/rules
        * Update .service and README.debian for new postgresql DB
      .
      python-faraday (2.7.2-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (2.7.1-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (2.7-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (2.6.3-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (2.6.2-0kali1) kali-experimental; urgency=medium
      .
        * Import new upstream release
        * Use couchdb with erlang17: previous version of couchdb breaks with new
          erlang version 20* in Kali (see bug 4139)
      .
      python-faraday (2.5.0-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (2.4.0-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (2.3.1-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
        * Add a patch to fix a syntax error
      .
      python-faraday (2.2.0-0kali2) kali-dev; urgency=medium
      .
        * Update patch remove-unwanted-checks.diff: keep the DB updates (see
          https://github.com/infobyte/faraday/issues/155)
      .
      python-faraday (2.2.0-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (2.1.0-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
        * Drop patch modify-configuration.patch: merged by upstream
        * Update the helper-script to wait for the server
        * Refresh patch remove-unwanted-checks
      .
      python-faraday (2.0.0-0kali4) kali-dev; urgency=medium
      .
        * Add a warning in postinst if couchdb_uri not set correctly
      .
      python-faraday (2.0.0-0kali3) kali-dev; urgency=medium
      .
        * Add missing dependencies
        * Drop user/password in config by default to simplify configuration
      .
      python-faraday (2.0.0-0kali2) kali-experimental; urgency=medium
      .
        * Do not run farday-server in postinst
      .
      python-faraday (2.0.0-0kali1) kali-experimental; urgency=medium
      .
        * Import new upstream release
        * Upstream didn't support qt3 anymore: update debian/rules (no more external
          library to download)
        * Add a patch to change the default ports of server
        * Add couchdb in depends
        * Add a .service to manage faraday-server and update the helper-script to
          use this
        * Add a debian/README.debian to explain how to configure
      .
      python-faraday (1.0.22-0kali2) kali-dev; urgency=medium
      .
        * Add a patch to copy the data/images directory in the user directory
          (Closes: 3429)
      .
      python-faraday (1.0.22-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
        * Add depends: python-twisted, python-sqlalchemy
        * Update installation: drop wget in debian/rules and debian/control
      .
      python-faraday (1.0.21-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (1.0.20-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (1.0.19-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (1.0.18-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (1.0.17-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
        * Refresh patch remove-unwanted-checks
      .
      python-faraday (1.0.16-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
        * Refresh patch remove-unwanted-checks
      .
      python-faraday (1.0.15-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
        * Update debian/copyright
        * Refresh patch remove-unwanted-checks
        * Update debian/install
      .
      python-faraday (1.0.14-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (1.0.13-0kali2) kali-dev; urgency=medium
      .
        * Move couchdb to Recommends... couchdb is badly maintained
          and a hard dependency makes it impossible to remove it even
          temporarily.
      .
      python-faraday (1.0.13-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (1.0.12-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
      .
      python-faraday (1.0.11-0kali1) kali-dev; urgency=medium
      .
        * Import new upstream release
        * Increase minimal required version of python-requests
      .
      python-faraday (1.0.10-0kalidev2) kali-dev; urgency=medium
      .
        * Update debian/rules for kali-dev: import an other version of qt3
      .
      python-faraday (1.0.10-0kali1) kali; urgency=medium
      .
        * Import new upstream release
        * Update debian files
        * Refresh patch remove-unwanted-checks
        * Drop patch upstream-patch as it's included in new version
      .
      python-faraday (1.0.7-0kali1) kali; urgency=low
      .
        * Initial packaging for kali.
        * debian/rules: as qt3 not available in kali, download a library provided by
          upstream (until a release that will use qt4) and exclude this library of
          dh_shlibdeps processing
        * Add an upstream patch to use the downloaded library qt and fix the qt
          directory
        * Add a patch to remove the unwanted functions: checkDependencies, update,
          checkUpdates.
        * Add depends to python-sip (not included in requirements.txt given by
          upstream)
        * Add minimal version 0.10.1 on depends python-sip
        * Add a helper-script
      232677ed