• Lorenzo Faletra's avatar
    Import Debian changes 3.1.1-0parrot1 · 5937a491
    Lorenzo Faletra authored
    python-faraday (3.1.1-0parrot1) testing; urgency=medium
    
      * Disable service autostart at boot.
    
    python-faraday (3.1.1-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (3.0.1-0kali1) kali-dev; urgency=medium
    
      * Update debian/watch to handle beta version
      * New upstream version 3.0.1
      * Update debian/copyright
      * Update install for new release
      * Refresh patches and remove fix-checkVersion.patch
      * Use debhelper 11 and update Standards-Version
      * Update dependencies
      * Remove build-dep dh-systemd (obsolete package)
      * Remove references to couchdb configuration
      * Add lintian-overrides
      * Clean up to fix several lintian warnings
      * Install the required empty directory migrations/versions
      * Change Architecture to All and clean d/rules
      * Update .service and README.debian for new postgresql DB
    
    python-faraday (2.7.2-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (2.7.1-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (2.7-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (2.6.3-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (2.6.2-0kali1) kali-experimental; urgency=medium
    
      * Import new upstream release
      * Use couchdb with erlang17: previous version of couchdb breaks with new
        erlang version 20* in Kali (see bug 4139)
    
    python-faraday (2.5.0-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (2.4.0-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (2.3.1-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
      * Add a patch to fix a syntax error
    
    python-faraday (2.2.0-0kali2) kali-dev; urgency=medium
    
      * Update patch remove-unwanted-checks.diff: keep the DB updates (see
        https://github.com/infobyte/faraday/issues/155)
    
    python-faraday (2.2.0-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (2.1.0-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
      * Drop patch modify-configuration.patch: merged by upstream
      * Update the helper-script to wait for the server
      * Refresh patch remove-unwanted-checks
    
    python-faraday (2.0.0-0kali4) kali-dev; urgency=medium
    
      * Add a warning in postinst if couchdb_uri not set correctly
    
    python-faraday (2.0.0-0kali3) kali-dev; urgency=medium
    
      * Add missing dependencies
      * Drop user/password in config by default to simplify configuration
    
    python-faraday (2.0.0-0kali2) kali-experimental; urgency=medium
    
      * Do not run farday-server in postinst
    
    python-faraday (2.0.0-0kali1) kali-experimental; urgency=medium
    
      * Import new upstream release
      * Upstream didn't support qt3 anymore: update debian/rules (no more external
        library to download)
      * Add a patch to change the default ports of server
      * Add couchdb in depends
      * Add a .service to manage faraday-server and update the helper-script to
        use this
      * Add a debian/README.debian to explain how to configure
    
    python-faraday (1.0.22-0kali2) kali-dev; urgency=medium
    
      * Add a patch to copy the data/images directory in the user directory
        (Closes: 3429)
    
    python-faraday (1.0.22-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
      * Add depends: python-twisted, python-sqlalchemy
      * Update installation: drop wget in debian/rules and debian/control
    
    python-faraday (1.0.21-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (1.0.20-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (1.0.19-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (1.0.18-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (1.0.17-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
      * Refresh patch remove-unwanted-checks
    
    python-faraday (1.0.16-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
      * Refresh patch remove-unwanted-checks
    
    python-faraday (1.0.15-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
      * Update debian/copyright
      * Refresh patch remove-unwanted-checks
      * Update debian/install
    
    python-faraday (1.0.14-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (1.0.13-0kali2) kali-dev; urgency=medium
    
      * Move couchdb to Recommends... couchdb is badly maintained
        and a hard dependency makes it impossible to remove it even
        temporarily.
    
    python-faraday (1.0.13-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (1.0.12-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
    
    python-faraday (1.0.11-0kali1) kali-dev; urgency=medium
    
      * Import new upstream release
      * Increase minimal required version of python-requests
    
    python-faraday (1.0.10-0kalidev2) kali-dev; urgency=medium
    
      * Update debian/rules for kali-dev: import an other version of qt3
    
    python-faraday (1.0.10-0kali1) kali; urgency=medium
    
      * Import new upstream release
      * Update debian files
      * Refresh patch remove-unwanted-checks
      * Drop patch upstream-patch as it's included in new version
    
    python-faraday (1.0.7-0kali1) kali; urgency=low
    
      * Initial packaging for kali.
      * debian/rules: as qt3 not available in kali, download a library provided by
        upstream (until a release that will use qt4) and exclude this library of
        dh_shlibdeps processing
      * Add an upstream patch to use the downloaded library qt and fix the qt
        directory
      * Add a patch to remove the unwanted functions: checkDependencies, update,
        checkUpdates.
      * Add depends to python-sip (not included in requirements.txt given by
        upstream)
      * Add minimal version 0.10.1 on depends python-sip
      * Add a helper-script
    5937a491
compat 3 Bytes